Forum Discussion

Mosh's avatar
Icon for Professor rankProfessor
7 years ago

UI Form Auto Complete Issue (chrome auto-fill username & password)

Please, please, please change the names of the username and password form elements in the data source edit UI from the highly generic "username" and "password".  Even though you have specified the autocomplete="off" attribute, Chrome will still fill in these fields on submit.  This has resulted in our data sources breaking a number of times causing false incidents.  A trick also known to work for Chrome is to use autocomplete="false" ("false" instead of the "off" value), but simpler to rename the INPUT elements to username_datasource and password_datasource or something similar.

@Sarah Terry
@Ali Holmes


6 Replies

Replies have been turned off for this discussion
  • These would work also:

  • Hi, can this please be moved up in priority?  It's caused a number of incidents for us now.  The problem is that when we click Save on a data source, Chrome is very quick to perform the autocomplete, usually in between the time it takes your client side script to gather the data and perform the POST back.  The dialog that comes up after clicking Save also gives the browser ample time to intercept with autocomplete.  Even clicking between data sources without making changes now triggers the "are you sure you want move away without saving" prompt because the code detects the autocomplete as changes to the data source.

  • This issue has been fixed in upcoming version 99 which is scheduled to be released January 11-18.