Forum Discussion

Kelemvor's avatar
Icon for Expert rankExpert
2 years ago

Anyone getting Switch COnfigs from Aruba switches?


We have some HP Aruba 2530-48G switches.  They are monitoring the basic info just fine, but LM is not pulling down the Configs like it does on some of our other switches.  Is there anything special I need to do to get the Aruba switches to have their config downloaded?

I saw an Aruba Config Source in the Exchange, but it didn’t work when I tried it.  If anyone knows how I can get this to work, please let me know.


5 Replies

  • Well, all I can see are ***s for the password so I didn’t know if it was right or not.  Anyway, I worked with LM chat and they had me import some additional things from some propertysources and configsources and now it seems to be working better.


  • I’ve just enabled this on Aruba switches.

    LM needs an SSH account in order to pull in the Config Files.  

  • I have the SSH account and password in the properties for the switch. Is there any way to see if it's trying to use it but maybe something is entered wrong? I don't see a config item in the list of things it's monitoring. I do see memory, now we're interfaces, cpu, and all the normal things.

  • If you check the “Info” Tab on the device in LM, you can see what is set for “ssh.user” and “ssh.password”  - if you see nothing there/wrong info you can apply those properties either individually or apply them via a folder - I made one for all of my Aruba switches and just applied the ssh.user / ssh.password to the folder to ensure they all had the proper login info.

  • by default, the passwords will always mask with ***’s whenever they’re in the correct field.

    Glad it’s working for you!