Question

Config listing doesn't allow crtl-f searching

  • 13 March 2023
  • 8 replies
  • 56 views

Userlevel 6
Badge +12

Looking for a CIDR range in a config source.  Can find using the old UI, not the new one.  ctrl-f doesn't seem to let me search within the config pane itself.


8 replies

Userlevel 6
Badge +12

More detail… the config doesn’t load the whole text into the pane to allow for searching a router config that is a few thousand lines of various IP addresses.

Userlevel 7
Badge +20

Similar to my experience where the whole thing doesn’t load after a pane resize.

Userlevel 5
Badge +7

Thanks for the feedback. To confirm I’m submitting the correct issue for our development team to review, are you talking about the functionality when you click on “Expand Changes” in the Configs tab? 

Userlevel 7
Badge +20

I don’t see an “expand changes” on the configs tab, but when i click on a version in the configs tab, yes.

Userlevel 6
Badge +12

Neither the initial view nor the expanded view shows the whole output… and neither seem to allow ctrl-f access to the text for searching.  The search I was doing was present and worked as expected in the old UI.

Userlevel 3
Badge +2

Neither the initial view nor the expanded view shows the whole output… and neither seem to allow ctrl-f access to the text for searching.  The search I was doing was present and worked as expected in the old UI.

When Cole and I were working on this I did some additional testing and Ctrl+F was able to parse the visible text in the config pane but scrolling away would cause those results to disappear completely.  By my estimation was it was seeing ~20 lines of the config at a time; looking at Stuart’s post where resizing the window still limited the visibility to 25 lines falls right into my experience.  

For further context we were attempting to search a config with ~6800 lines of data, so you can see how 20-25 lines at a time isn’t going to do any good.  We’re using Ctrl+F because there is no in-pane search function for the config data.

Userlevel 7
Badge +20

Let me know if you guys would prefer this in a separate thread, but to me it’s all related:

When viewing a multi-instance config, if you:

  1. View an instance
  2. Click/select on one of the configs in that instance
  3. Switch instances by clicking a different instance in the tree

The right hand pane reloads, but the bottom pane where it’s showing the config does not show the most recent version of the selected config. Even though it has been redrawn, and all indicators are that you’re looking at a different instance, it still shows the same instance you were looking at originally. It’s not until you select an specific config version from the back up that you actually see the bottom pane reload with the correct info. This is confusing. I spent 5 minutes switching between instances not believing what I saw because they were all showing the results of “show version” (cisco ios), which is completely different from the inventory, running, and startup configs.

Userlevel 5
Badge +7

Hi Stuart - I went ahead and submitted a separate issue about the multi-instance config option. 

Reply