Forum Discussion

Mosh's avatar
Icon for Professor rankProfessor
5 years ago

New Alert UI Filters

The new Alert UI no longer appears to support negative filters, e.g. !(Test) if I want to exclude a DataPoint that has "Test" in the string. 

This worked very well in the old Alert UI and we use it a lot.

5 Replies

Replies have been turned off for this discussion
  • Hey @Mosh, I believe the issue you are running into is due to having to scroll to add your string to the filter. See the screenshot attached, you have to scroll to the bottom of the filter auto-complete menu and select the "Create ___" option. Let me know if that helps. Thanks! 

  • Hi @Linus

    I tried that, but still the filter was ignored and did not work as it does in the old Alert UI.

  • Hey @Mosh, I've tested this and have not been able to reproduce the issue. 

    Would be great if we could connect and you could show me exactly where and how you are running into this issue. I will send you an email. 

    Thanks, apologize for the inconvenience. 

  • Hi @Linus, thanks for looking into this further.  I can confirm that if I use !(*Test) in the new UI it now excludes correctly.  Weird that !(Test) worked fine in the old UI though.


  • I just tried this as well and it is definitely cumbersome.  There is no completion when you start with ! and if you use completion, there is no opportunity to prepend the !.  I would hope with such a major revamp that a complex expression editor would be part of the upgrade :(