Forum Discussion

ssplat's avatar
5 years ago

can't turn alert off for specific instances with Ansible

Hi Everyone,

The LogicMonitor module for Ansible has that specific parameter 'alertenable' while using 'datasource as target to turn off alerts for specific instance in datasource group. However it's not working for me. Did anyone ever tried to use that parameter?

- hosts: localhost
    company: mycompany
    user: myusername
    password: mypassword
  - name: Create a host group
      target: datasource
      action: update
      alertenable: no
      id: 123
      company: '{{ company }}'
      user: '{{ user }}'
      password: '{{ password }}'

2 Replies

Replies have been turned off for this discussion
  • I'm trying to turn off the alerting for 'Memory usage' instance for a specific device, not all monitored instances on that device. 

  • Adding an action that isn't 'sdt' errored out with following message  {"msg": "Error: Unexpected action \"add\" was specified."} or this if i don't pass any action parameter {"msg": "missing required arguments: action"}. SDT is not what i'm trying to do.