No you can't. Failover is determined by a lack of connectivity between the primary collector and the platform. Once that reaches a certain amount of absent data, the platform switches the tasks to the failover collector. As far as I know the only way you could do that would be to stop the services on the primary collector.
Kiyoshi_Egawa
OP3 years ago
Can I use any API to make failover collector in force ?
Kiyoshi
LM User
·3 years ago
If you have the collectors configured to fail over in LM, the services do run, however the platform will not assign any tasks to the collector except for the collector to monitor itself. Once failover happens, the tasks for the devices monitored by the primary collector will be instead assigned to the failover collector. The services run in all cases at all times. This helps with fast failover.
Kiyoshi_Egawa
OP3 years ago
I means collectors are installed ready for failover. I may mistake to use the word cold standby. If the warm stanby means collector services just start in failover process, I want to do it.
Starting serivces means :
service logicmonitor-watchdog start
service logicmonitor-agent start
Is the warm standby workable ? Can it do monitoring failover for text log file on shared disk of cluster software ?
Kiyoshi
LM User
·3 years ago
Theoretically you could script the collector download/install. There would be a small gap in monitoring, but that could achieve what you are looking for.
I can’t remember the specifics, but I believe if you install the collector and shutdown it down, then start another with the same config, after awhile there is a key like rotation that would be missed and the cold standby would just be rejected by the portal.
That’s true. Would be better to just stand up a new collector with the same ID. You can do this in a container pretty easily. Setup docker on both machines and setup a swarm. Then just configure the number of collector services to 1.
Joe Williams
·3 years ago
Theoretically you could script the collector download/install. There would be a small gap in monitoring, but that could achieve what you are looking for.
I can’t remember the specifics, but I believe if you install the collector and shutdown it down, then start another with the same config, after awhile there is a key like rotation that would be missed and the cold standby would just be rejected by the portal.
Kiyoshi_Egawa
OP3 years ago
I would like to control collector start/stop by cluster software. Because it must be synclonizing between Fluentd and Collector faiover to avoid working Fluentd and Collctor on different host.
Kiyoshi
LM User
·3 years ago
Is there a particular reason you would want to do this? The warm stand by capability built in to LM basically does this same thing.
Kiyoshi_Egawa
OP3 years agoOK, thank you. We will go forward.
Kiyoshi
LM User
·3 years agoNo you can't. Failover is determined by a lack of connectivity between the primary collector and the platform. Once that reaches a certain amount of absent data, the platform switches the tasks to the failover collector. As far as I know the only way you could do that would be to stop the services on the primary collector.
Kiyoshi_Egawa
OP3 years agoCan I use any API to make failover collector in force ?
Kiyoshi
LM User
·3 years agoIf you have the collectors configured to fail over in LM, the services do run, however the platform will not assign any tasks to the collector except for the collector to monitor itself. Once failover happens, the tasks for the devices monitored by the primary collector will be instead assigned to the failover collector. The services run in all cases at all times. This helps with fast failover.
Kiyoshi_Egawa
OP3 years agoI means collectors are installed ready for failover. I may mistake to use the word cold standby. If the warm stanby means collector services just start in failover process, I want to do it.
Starting serivces means :
LM User
·3 years agoTheoretically you could script the collector download/install. There would be a small gap in monitoring, but that could achieve what you are looking for.
I can’t remember the specifics, but I believe if you install the collector and shutdown it down, then start another with the same config, after awhile there is a key like rotation that would be missed and the cold standby would just be rejected by the portal.
That’s true. Would be better to just stand up a new collector with the same ID. You can do this in a container pretty easily. Setup docker on both machines and setup a swarm. Then just configure the number of collector services to 1.
Joe Williams
·3 years agoTheoretically you could script the collector download/install. There would be a small gap in monitoring, but that could achieve what you are looking for.
I can’t remember the specifics, but I believe if you install the collector and shutdown it down, then start another with the same config, after awhile there is a key like rotation that would be missed and the cold standby would just be rejected by the portal.
Kiyoshi_Egawa
OP3 years agoI would like to control collector start/stop by cluster software. Because it must be synclonizing between Fluentd and Collector faiover to avoid working Fluentd and Collctor on different host.
Kiyoshi
LM User
·3 years agoIs there a particular reason you would want to do this? The warm stand by capability built in to LM basically does this same thing.